Power Window Trouble

stretchmiester

New member
Joined
Jan 13, 2005
Messages
1
Reaction score
0
Points
0
Age
41
hey i got a problem on my rora and need some help. im in college and left for xmas break and my power windows were working fine (exception being the drivers side front that goes down about an inch then stops). after coming back from the break, now my enitre passenger side, front and back do not work. the power seats work on both sides and all the gadgets on the passenger side work normal. my drivers side window still goes down an inch or so and the back drivers side window works great, but the passenger side windows do not even react or make any noise when either my controls or the passenger switches are pushed. i have checked to what i believe to be every fuse in that car (the fuse panel and both under the back seat) and none were fried. i have no clue about the circuit breakers or other little black boxes though. the power seat breaker and the window breaker are the same so i switched them to see if the window one was fried and they both work fine. any help? i think my drivers side is the motor, but the whole passenger side??? it has sat and not been started for 4 weeks over break so i want to believe it is something electrical and not the motors. any help would be great for this poor college student!
 

Oldsman

New member
Joined
Oct 11, 2004
Messages
5
Reaction score
0
Points
0
Age
41
Location
Ontario, Canada
Stretchmeister,

I had a problem with power windows on a Ciera. It turns out my fix would apply to any car. I did the same thing as you by checking the circuits and breakers etc. Finally a guy at work told me to slit open the rubber boot where the wires come from the car and into the doors. Start with the drivers door because it most likely gets the most use. The problem he said could be broken wires insid the boot caused by the constant flexing when the door is opened and closed. Went home, tried it and bingo!! 2 broken wires. I repaired them with wire splices and they still work great. Just a maybe thats where your problem is. It's worth a look.

Oldsman
 
J

jesus

Guest
:p Ihad the same problem with my 01, Olds Aurora all of the windows worked except the right front. When I pressed/pull the switch , nothing very little noise like it wanted to roll down but no way. So I took the door off panel so that I could check the power window motor assembly. I took off the three of four bolts that hold the power window motor and tested it with out being connected to the window, and it worked just fine it turn both ways clockwise, and counter closck wise so then I reconnected it to the window and it started working just fine, this was about three months ago and its stil lworking fine, I guess the motor just became stuck.
Originally posted by stretchmiester@Jan 13 2005, 12:13 PM
hey i got a problem on my rora and need some help. im in college and left for xmas break and my power windows were working fine (exception being the drivers side front that goes down about an inch then stops). after coming back from the break, now my enitre passenger side, front and back do not work. the power seats work on both sides and all the gadgets on the passenger side work normal. my drivers side window still goes down an inch or so and the back drivers side window works great, but the passenger side windows do not even react or make any noise when either my controls or the passenger switches are pushed. i have checked to what i believe to be every fuse in that car (the fuse panel and both under the back seat) and none were fried. i have no clue about the circuit breakers or other little black boxes though. the power seat breaker and the window breaker are the same so i switched them to see if the window one was fried and they both work fine. any help? i think my drivers side is the motor, but the whole passenger side??? it has sat and not been started for 4 weeks over break so i want to believe it is something electrical and not the motors. any help would be great for this poor college student!
[snapback]4478[/snapback]​
 

Drew

New member
Joined
May 4, 2005
Messages
66
Reaction score
0
Points
0
Well, since ALL the switches run through the master one because of the window lock, remove the master panel on the drivers side and clean all the contacts until they are nice and shiney again. If the problem persists, then go onto the boot. This is not all that uncommon on the aurora, and several people have had this problem on the ACNA forum, and this has fixed it.

Good Luck!
 

auroralover

New member
Joined
Jun 6, 2005
Messages
16
Reaction score
0
Points
0
Age
41
I took my 01 in for the right front window not working also. You could hear a click when you pressed the switch, but nothing happened. I took it to a glass shop my company uses, and they called me and said it needed a regulator, and they would have to order it from Louisville, and that would take a day. I said ok, but I need the car today. So, I picked it up, and the mechanic said he got the window working. He said the motor gets a "flat" spot in it, and if you take the door panel off and tap it with a hammer lightly, it will work again. Could work for 2 days or 6 months he said. Sorry for the long post, just thought it might help someone. BTW, I went ahead and replaced it. The motor and regulator are one piece.
 

William Bramlett

New member
Joined
Apr 13, 2021
Messages
1
Reaction score
0
Points
0
Does anyone know of a substitute part for the power window master control? Another car with similar contruction
 
Top