new owner to an '01 oldsmobile aurora and having several problems

01oldsmobileaurora

New member
Joined
Nov 7, 2011
Messages
1
Reaction score
0
Points
0
.....locks dont work except driver
.....high beams dont work right
.....wipers dont work
.....windows dont work except drivers window
......passenger window leaks
......sunroof leaks
.......screen reads tire gauge low...so i pumped them up with pump to 35 and reset button and it still says tire pressure low
not familiar with this car at all just goit it and need advice on how to fix these problems:rolleyes:
 

2001 Aurora

New member
Joined
Aug 30, 2011
Messages
1
Reaction score
0
Points
0
The driver side locks and window issue.

I drive a 2001 3.5.

I had the exact same issue with my car. Power windows and locks did not operate on the passenger side.

The problem with my car was a rusted/corroded control wire that ran under the seat. I had it replaced at a dealership for $650-$700 this past summer in Toronto Ontario.
 

oldmak01

New member
Joined
Nov 24, 2011
Messages
30
Reaction score
0
Points
0
Don't worry we got you

Hello and congrats on a great purchase. I have had the same problems that you have but there are a lot of people that can help ya. the windows in the back on most 01-03 auroras don't work because of the regulators acting up or just plain breaking(i have a 01 caddy deville, 01 and 02 Aurora, 01 bonneville, and two Rivieras and the Auroras, caddy and that dang bonneville all have window problems). First you need to test them so take off the door panels and look in(on one of my Auroras and the caddy, the previous owners put sticks of wood under the windows to keep them from falling instead of fixing them, and one guy used a pair of vise grips to)and make sure the connections are good, check the fuses but I bet its the regulators. As for the high beams check the bulb and the connections with them for burns and corrosion. wipers check fuse(the combonation switch could be bad and that could explain the hi beams also). Passenger window may not be up all the way since it has no response check for a rusted wire under the seat on that side of the car. sunroof you want to check the drain tubes and make sure it is closed all the way, you may have to close it then push up on the rear to make sure it is even with the rest of the roof from the outside(pain I know). What wheels do you have(four different versions), the crome wheels tend to leak because of corrosion in any case have the leaking tire taken off the rim and have the rim clean where the tire bead meets the rim and then resealed this should take care of the low pressure gauge anything just hit me up and let me know how everything works out. Over all these are great cars so don't let the little stuff get ya down
 
Last edited:
Top