hvac control panel

radiotech

New member
Joined
Jun 3, 2005
Messages
5
Reaction score
0
Points
0
Age
41
2000 intrigue automatic climate control panel goes dead at times and comes back on .is there a way to reset or pull codes from unit?trouble started recently.all functions work fine when display is on ,nothing works when display is off.Any ideas??
 

acrazyangel

New member
Joined
Jul 6, 2005
Messages
8
Reaction score
0
Points
0
Age
41
Originally posted by radiotech@Jun 3 2005, 09:51 AM
2000 intrigue automatic climate control panel goes dead at times and comes back on .is there a way to reset or pull codes from unit?trouble started recently.all functions work fine when display is on ,nothing works when display is off.Any ideas??
[snapback]7810[/snapback]​

Go and have a basic computer scan on the computer system. It shouldn't cost very much (mine cost only $20). Have you had any problem with the cruse control?
 

rqrock1

New member
Joined
Jun 28, 2005
Messages
80
Reaction score
0
Points
0
Age
41
the only way to get codes out of it is to use a tech2 or another scan tool. is that the only display that blanks out? like the cluster is ok?
 

radiotech

New member
Joined
Jun 3, 2005
Messages
5
Reaction score
0
Points
0
Age
41
I put the innova 3100 code reader on and there are no codes present.I cant tell you about the cruise control because I have not used it recently.It doesnt matter if the car is cold or warm the dash unit behaves erraticly.when it does work the ac vent temp is 40 degrees.I hate to buy a new unit only to have it do the same thing.thanks for the replies.
 

rqrock1

New member
Joined
Jun 28, 2005
Messages
80
Reaction score
0
Points
0
Age
41
sounds like the a/c control head is going dead.
 

acrazyangel

New member
Joined
Jul 6, 2005
Messages
8
Reaction score
0
Points
0
Age
41
The problem could be a that the main computer is not talking to the A/C unit. That is one of the many problems my Olds is having right now. Since my basic scan showed that there was a problem/defect with the PCM (main computer in car), I called Oldsmobile today and they informed me that the PCM has a warranty on it from GM that is 8ys/80,000 mile. If you would like more information you can call Oldsmobile @ 1-800-442-6537. Have you Vin number with you when you call, they will help you . I hope this helps.
 

radiotech

New member
Joined
Jun 3, 2005
Messages
5
Reaction score
0
Points
0
Age
41
I picked up a control unit from a junk yard for 175.00 and would you believe it does the same thing,anyways the car is at the dealer now and they say I need a new controller.It also affects the cruise control to not work either.There is a gal on another message board who has the exact same problem I have and she just had her dash unit replaced for 600.00.and the car is going back to her dealer because it too is doing the same thing.I do not understand what the problem could be ,maybe defective pcm??Why now after all these years??
 

CutlassSupreme3800

New member
Joined
Dec 25, 2004
Messages
265
Reaction score
0
Points
0
Age
41
Location
Michigan
Originally posted by acrazyangel@Jul 14 2005, 02:06 AM
The problem could be a that the main computer is not talking to the A/C unit. That is one of the many problems my Olds is having right now. Since my basic scan showed that there was a problem/defect with the PCM (main computer in car), I called Oldsmobile today and they informed me that the PCM has a warranty on it from GM that is 8ys/80,000 mile. If you would like more information you can call Oldsmobile @ 1-800-442-6537. Have you Vin number with you when you call, they will help you . I hope this helps.
[snapback]9915[/snapback]​


^this seems to be most logical explanation to me at least
 

radiotech

New member
Joined
Jun 3, 2005
Messages
5
Reaction score
0
Points
0
Age
41
got my car back from dealer today,was in for 4 days.originally they said the dash control unit was bad (580.00)plus labor,then they called back the next day and said tech misdiag. need more time to find problem.(new unit did the same thing blinks goes dead,freezes and cruise control did not work).bottom line...defective ignition switch (150.00).all is well so far
 

tbullock

New member
Joined
Sep 22, 2005
Messages
5
Reaction score
0
Points
0
I have the same problem... Intermittent HVAC Unit

I have had the same problem since I bought my car about 5 months ago. The HVAC and Cruise Control will work intermittently (at best). The display on my HVAC control unit sometimes has is on and allows me to control the temperature like it should. Other times it is locked and I can't change the temperature or any of the settings even though the display is on. Still other times the display is plain old dead and I end up driving around with absolutely nothing in the way of AC or Heat.

Have any of these problems reappeared for you or are they gone?

If so I'll bring my car in with a print off of this thread and get them to start with the ignition switch.

Winter is comming soon so I have to get this handled ASAP.

If anyone else has had this problem, please let me know if you solved it or not. If so, how?

Thanks

-Ted
 

radiotech

New member
Joined
Jun 3, 2005
Messages
5
Reaction score
0
Points
0
Age
41
HVAC Control Panel works great and has not failed since new ignition switch replaced,good luck
 

tbullock

New member
Joined
Sep 22, 2005
Messages
5
Reaction score
0
Points
0
Will reply

Ok,

Good to know.

I will repost with the results in a few weeks when the work has been done.

Thanks.

-Ted
 

raymundo1

New member
Joined
Feb 27, 2006
Messages
2
Reaction score
0
Points
0
Intermmitent problem with the HVAC

Do you guys have an update on this problem. My Oldsmobile intrigue 2000 has been having this problem for over 2 months now and you know with winter already here my wife wants this fixed ASAP!!!!!HELP!!!!!
 

moogvo

New member
Joined
Dec 19, 2007
Messages
51
Reaction score
0
Points
0
Location
Hazzard County, NC
I noticed on my '02 that when the failure is occuring that when you turn the fan knob to "off" the "Cruise" light on the dash cluster lights up. This leads me to believe it is a bad ground of sorts.

I have noticed that sometimes when I shut the car off and then re-start it, all is well. Other times I have pounded the dash over the center vents and it has started workig again.
 

rwaldron

New member
Joined
Jan 9, 2008
Messages
1
Reaction score
0
Points
0
Climate control unit Fails to power up

I have a 1999 Olds Intrigue with the automatic climate control. My Intrigue presented with a climate control that would not power up consistently. At some points it would power up but would not actuate the blower, suggesting a failed blower or resistor. The presentation suggested failure to link with the main computer as well. For a week or so it might work fine, then turn off for a few days then come back on. The cruise control did not work but, I assumed this was a separate failure; ultimately this was a false assumption on my part.

I replaced the Climate control unit twice, the second time with a rebuild. I had the rebuild retested and found it was good. I then started with a voltmeter to try and track down the problem. There are three critical wires in the climate control plug. The orange and brown should both show about 13.5 volts. And the Black wire should be tested for adequate ground. I was getting variable power readings of 4 to 10 volts on the brown wire. When you load the circuit with some draw, such as a tail light bulb, you will really see a voltage drop. I moved to the fuse block and tested the orange & brown there and found the same low voltage. After reading how some folks here on Olds forum had repaired their similar problem with a new ignition switch, I decided to give it a shot before I took it to a dealer. In my case this was all caused by the failed ignition switch. They run anywhere from $76.00 at the online auto parts store "Rock Auto" to around $90.00 at AutoZone, or Oriely It should be about a one-hour job for a Tech that knows what he is doing. There is also a write up on this site that indicates how to R & R the Switch.

After replacing the ignition switch the climate control worked fine. The non-working cruise control also works after the ignition switch replacement. I have worked on cars now for many decades; this is one of the most difficult diagnostic jobs I have ever faced. I fail to understand the need to engineer a car this way. There have been ongoing reports of electrical issues with the Intrigue, when looking at the Pontiac Grand Prix as a comparative baseline, you have to wonder why all the electrical problems with the Intrigue???? Thanks to all that contributed to this solution here on Olds Forum. Your help and support is very very much appreciated. Keith Waldron Minneapolis, MN
 

wfreeth

New member
Joined
Jun 4, 2009
Messages
2
Reaction score
0
Points
0
I'll have to look at my ignition switch too, my HVAC won't start up sometimes and the Curise control does not work at the same time. I can pull my key out of the ignition switch while the car is running, it's pretty loose.
 

conradlamb

New member
Joined
Mar 23, 2009
Messages
2
Reaction score
0
Points
0
Location
Missouri
Apparently I have a loose odometer reading display and it only illuminates after tapping on the dash. How do you access this to secure the electrical connection?
 

brwneyes426

New member
Joined
Feb 13, 2010
Messages
1
Reaction score
0
Points
0
I'll have to look at my ignition switch too, my HVAC won't start up sometimes and the Curise control does not work at the same time. I can pull my key out of the ignition switch while the car is running, it's pretty loose.

Did you ever find out what the problem was?
 

gmf1

New member
Joined
Aug 28, 2012
Messages
1
Reaction score
0
Points
0
new ignition switch fixed climate control and more

Just put a new ignition switch in my 99 Intrigue and it fixed the climate control system that used to go on and off. It also fixed the cruise control, rear defrost and stopped compass and headlights from flickering.
The ignition switch replacement post on this Intrigue forum by LittleHoov was EXCELLENT. Thank you very much !
 
Top