Error codes - car shutting off while driving

Jhow

New member
Joined
Mar 26, 2020
Messages
1
Reaction score
0
Points
0
My car (2002 intrigue) started to lose power while driving and sometimes fully shutoff at lower speeds. I scanned it and it showed codes for an ignition coil. I replaced the ignition coil and spark plugs but it persists and shows the error codes as follows:
Crankshaft position sensor-circuit malfunction
Ignition coil-cylinder 2- early activation fault

I'm wondering what the true problem is? Replacing a sensor or something to do with the timing. Thanks for the help.
 

C&C

Member
Joined
Mar 2, 2010
Messages
630
Reaction score
0
Points
16
Location
Mount Pleasant, SC
Crankshaft position sensors have been implicated in some engines as trouble areas; first check the connector, wiring to connector, then maybe replacement of sensor.
 

Evgeny

New member
Joined
Jan 4, 2012
Messages
4
Reaction score
0
Points
1
My car (2002 intrigue) started to lose power while driving and sometimes fully shutoff at lower speeds. I scanned it and it showed codes for an ignition coil. I replaced the ignition coil and spark plugs but it persists and shows the error codes as follows:
Crankshaft position sensor-circuit malfunction
Ignition coil-cylinder 2- early activation fault

I'm wondering what the true problem is? Replacing a sensor or something to do with the timing. Thanks for the help.
I have 2000 Intrigue, and currently observed similar problem - car shuts off. One day, during drive when I slow down to make turn and only after I switch turning lights (left or right). It happened several times after long ride. When I started engine there was no error on dashboard. The next day I did test drive and found that car shuts off when during drive I hit brakes hard to make stop.
Did not observe errors on dashboard. I have cleaned ignition switch contacts, turning lights contacts, replaced EGR and idle valve.
Now after hard brake I can see error code B1440. Suspect that original problem is still there, because before all this troubles started, the error B1440 showed up first and later (after several weeks) started car shut off. Does anybody know how to fix Intrigue error B1440?
 
Top