EGR ? 1991 Trofeo

alvissaladin

New member
Joined
Jul 29, 2013
Messages
32
Reaction score
0
Points
0
Location
Germany
May be I´m blind! Were in hell I can find the EGR on the 3.8 in my 1991 Trofeo?

I heard about a better running of the engine and no more "service engine soon" light if I cleaned this egr thing. On my 1988 Trofeo it is clearly visible near of the right valve cover. But on my 1991 tuned port one I cannot find it.

A picture would be great !
 

1970cs

New member
Joined
Jan 9, 2014
Messages
218
Reaction score
0
Points
0
Location
Grand Ledge MI
198357_Graphic_559.jpg
 

alvissaladin

New member
Joined
Jul 29, 2013
Messages
32
Reaction score
0
Points
0
Location
Germany
Sorry 1970cs, your picture show the 3,8l till 1990 - like that one (VIN C) in my ´88 trofeo .
The 1991 Engine (VIN L ,3800 tuned port injection) has a very different intake and the egr is not at the former place:

19870463tu.jpg


19870464uy.jpg


I tried to understand the 1991-1992 emission controls and took my illustrated parts catalogue 1986-92 OLDSMOBILE "E" Toronado as a reference. If anyone own this helpfull book too: please look at page 3-40 at 3.000 group 1991-1992 E EMISSION CONTROLS-V6 3.8 (L27). It use 96 different parts but NO EGR is listened. Am I right?

regards
Roland
 
Last edited:

Gator

New member
Joined
Oct 4, 2014
Messages
14
Reaction score
0
Points
0
Your second picture doesn't quite show where the EGR should be. I think yours should be located next to the valve cover (on driver side). Look straight down and see if the connection to the exhaust header is there (or perhaps plugged in the case of an EGR delete).
 

Cutlass350

New member
Joined
Aug 20, 2012
Messages
655
Reaction score
1
Points
0
Location
New England! :-)
Your second picture doesn't quite show where the EGR should be. I think yours should be located next to the valve cover (on driver side). Look straight down and see if the connection to the exhaust header is there (or perhaps plugged in the case of an EGR delete).

Yup, from nalleyGMC:

It's part #515, on the right, near the top.

From:
http://parts.nalleygmc.com/products/VALVE-Emission-Control-System/2879636/19187311.html

941021GM00-255.JPG




What it should look like:
From RockAuto:
ACDELCO Part # 2142129 {#19187311}
VALVE,EGR 2 DOORS
$139.79

https://www.rockauto.com/dbphp/x,catalog,321,partnum,2142129,d,ACDELCO_2142129.html


214-2129_Primary.jpg



309-EGR1049.jpg
 
Last edited:

alvissaladin

New member
Joined
Jul 29, 2013
Messages
32
Reaction score
0
Points
0
Location
Germany
Thanks for the replies, but again: original parts catalogue shows NO EGR for 1991 and 1992 Toronado engines.

My engine (original L27) has no fitting or any mounting for an EGR or the egr pipes or egr electrical connector and no pluged or closed (welded) hole in the exhaust pipes what could be an evidence for a former existed EGR.

Also I do not believe that a 3.8 would work with a (homemade) complete eleminated egr system.
The drawing from cutlass350 must shows a later engine (1993 up) or from another car. Drawing date shows 1994!

I m not the only last generation 91/92 toronado/trofeo owner in this forum, I guess. Friends, takes a closer look to your engines, please.

Roland

I found this answer in this thread http://pontiacbonnevilleclub.com/forum/viewtopic.php?f=12&t=6161

Just for note...

GM used the Tuned Port 3800 without an EGR from 1990( in some models ) to 1992... And the 3300 v6 from 1989-1993 also did not have an EGR..

Both of these engines passed emissions without the aid of EGR valves... But over a short time GM found that these engines were burning exhaust valves and cracking the tubular manifolds due to the higher combustion temperatures...

In 1993 GM reinstated the EGR Valve on the 3800 Vin L Tuned Port... The 3300 did not get the EGR as it was in its last year of production..

I have seen both the EGR'less 3800 and 3300 with Burnt valves.. This was not a Problem on the 3.8 Vin 3 or the 3800 Vin C as both of these had an EGR valve..
 
Last edited:

Rocketguy

Active member
Joined
May 9, 2005
Messages
1,164
Reaction score
0
Points
36
Location
Southeast Michigan
I heard about a better running of the engine and no more "service engine soon" light if I cleaned this egr thing.

You "heard about"?

I noticed that you make no mention of what exactly "this EGR thing" has to do with your SES light.

If your SES light is on have you found out why? Have you pulled the codes?

From the helpful posts it looks as though your car came w/o an EGR, therefore, could it even have a SES code for one?
 

alvissaladin

New member
Joined
Jul 29, 2013
Messages
32
Reaction score
0
Points
0
Location
Germany
@ rocketguy

Thanks for reply. The last generation toronado were never official exported to europe. It is one of these cars found the way to germany with privat shipment or as a leaved car from an american soldier. Also I believe it could be the only IV generation Trofeo in germany. I´m so happy that I´ve found it.

You are right - I haven´t checked any codes because I can not. The instrument cluster is dead ( I opened another thread some days before).
The engine starts and runs well, but it has an slightly rough idle with little missfire. Thats the reason why I hoped to clean the egr will fix it. I know - its like fumble around the dark.

Just ordered a working cluster at trofeoparts.com. Dave is very helpfull there.
So I hope to read the codes next time if the cluster arrive.
 

Sevish

New member
Joined
Dec 25, 2017
Messages
1
Reaction score
0
Points
0
Thanks for the replies, but again: original parts catalogue shows NO EGR for 1991 and 1992 Toronado engines.

My engine (original L27) has no fitting or any mounting for an EGR or the egr pipes or egr electrical connector and no pluged or closed (welded) hole in the exhaust pipes what could be an evidence for a former existed EGR.

Also I do not believe that a 3.8 would work with a (homemade) complete eleminated egr system.
The drawing from cutlass350 must shows a later engine (1993 up) or from another car. Drawing date shows 1994!

I m not the only last generation 91/92 toronado/trofeo owner in this forum, I guess. Friends, takes a closer look to your engines, please.

Roland

I found this answer in this thread http://pontiacbonnevilleclub.com/forum/viewtopic.php?f=12&t=6161

Just for note...

GM used the Tuned Port 3800 without an EGR from 1990( in some models ) to 1992... And the 3300 v6 from 1989-1993 also did not have an EGR..

Both of these engines passed emissions without the aid of EGR valves... But over a short time GM found that these engines were burning exhaust valves and cracking the tubular manifolds due to the higher combustion temperatures...

In 1993 GM reinstated the EGR Valve on the 3800 Vin L Tuned Port... The 3300 did not get the EGR as it was in its last year of production..

I have seen both the EGR'less 3800 and 3300 with Burnt valves.. This was not a Problem on the 3.8 Vin 3 or the 3800 Vin C as both of these had an EGR valve..

Hi I’m having the same problem with my 92 olds 88 royal LS so if certain engine models don’t have an egr to replace to bring engine temp down and reburn gas how do I get it to pass emissions in Colorado? I passed on everything but NOx 3 times what could be wrong ? Or needs replacing? I’ve even tried sea foam
 
Joined
May 17, 2021
Messages
1
Reaction score
0
Points
1
@ rocketguy

Thanks for reply. The last generation toronado were never official exported to europe. It is one of these cars found the way to germany with privat shipment or as a leaved car from an american soldier. Also I believe it could be the only IV generation Trofeo in germany. I´m so happy that I´ve found it.

You are right - I haven´t checked any codes because I can not. The instrument cluster is dead ( I opened another thread some days before)
The engine starts and runs well, but it has an slightly rough idle with little missfire. Thats the reason why I hoped to clean the egr will fix it. I know - its like fumble around the dark.

Just ordered a working cluster at trofeoparts.com. Dave is very helpfull there.
So I hope to read the codes next time if the cluster arrive.
I see this is an old thread but I'm having exact same problem. No dash slight rough idle. Was wondering if fixing dash fixed rough idle??? I tried fixing dash by using a local guy but he may have missed something cause it didn't fix anything. I put a BCM in but no change. I have coils coming just cause I found 3 dif brands installed in it. I'm wondering if pcm is bad causing all my problems. No dash only rpm interior lights come on then off with a flash when I hit switch on dash panel. Do not work with doors open. Defrost is stuck on. And I'm not 100% but I don't think abs is working either. I have a service manual trying to figure this car out.
 

JMorlan

New member
Joined
Dec 19, 2005
Messages
11
Reaction score
0
Points
1
I see this is an old thread but I'm having exact same problem. No dash slight rough idle. Was wondering if fixing dash fixed rough idle??? I tried fixing dash by using a local guy but he may have missed something cause it didn't fix anything. I put a BCM in but no change. I have coils coming just cause I found 3 dif brands installed in it. I'm wondering if pcm is bad causing all my problems. No dash only rpm interior lights come on then off with a flash when I hit switch on dash panel. Do not work with doors open. Defrost is stuck on. And I'm not 100% but I don't think abs is working either. I have a service manual trying to figure this car out.
What codes are being set on the computer?
 
Top