AC problem : warm air driver side, cold air passenger side

panther

New member
Joined
May 12, 2010
Messages
17
Reaction score
0
Points
0
I have an AC problem - warm air delivered from driver side vents and cold air from passenger side vents.

I recently had my AC serviced, about 1 week later problem described above was noticed. Took back to mechanic, dye was added to system and then recharged. System worked fine - cold air from both sides. Except, same thing happened 1 week later. Took back to mechanic no dye leek was seen. High valve tightened (seemed not as tight as should be), dye added, system recharged. Again, AC worked fine - cold air from both sides until exactly 1 week later. I will be taking car back to mechanic this week. In meantime...

My research on this forum indicates possibly a driver side electric actuator blend motor malfunction.

First - any ideas on a diagnoses scheme, test or other reasons?
Second - does anyone have a diagram on the location of the actuators and instructions on how to remove and replace them

Thanks in advance for any help offered
 

panther

New member
Joined
May 12, 2010
Messages
17
Reaction score
0
Points
0
Sorry - in regards to my AC problem post I forgot to identify car - its a 2001 Oldsmobile Intrigue GLS 6cyl

thanks again
 

justtrying

New member
Joined
Aug 22, 2009
Messages
184
Reaction score
0
Points
0
You are dealing with a real mechanic and you want help from us? This is what the mechanic is being paid for!
 

panther

New member
Joined
May 12, 2010
Messages
17
Reaction score
0
Points
0
justtrying...are you serious...i am really surprised at your response!

First - I have "only" paid the mechanic for the original AC service. Each time the car has been brought back the service (tech time and coolant material for recharge) and trouble shoot attempts have been free of charge. As per guarantee of original service rendered. And because the mechanic is a good guy who takes pride in his job!

Second - mechanics are not perfect and some situations are just difficult to diagnose.

Third - these forums were created and exist for a good reason. To be educated and informed consumers. So that if we desire and are capable, we can properly maintain, diagnose and fix the cars ourselves. Help others trouble shoot with similar situations efficiently and accurately. And to ensure that we are not taken advantage of whenever possible.

Finally - almost every thread on this forum is approached as a similar situation I presented. I have never seen a response as rude, unnessary and unhelpful as yours.
 

sparcx

New member
Joined
Dec 1, 2006
Messages
327
Reaction score
0
Points
0
Seems like the amount of refrigerant should be checked again a third time before moving on to some sort of other possible solution. Perhaps the leak was missed both the first and second time by the mechanic?
 

C&C

Member
Joined
Mar 2, 2010
Messages
636
Reaction score
3
Points
18
Location
Mount Pleasant, SC
If you are blowing cold on the passenger side you don't have a refrigerant problem; check the vacuum lines for leaks/breaks/etc. or a sticking damper door. Also, it might be electrical, as the Service Manual mentions as also a possibility (but it went way over my head on what was needing to be checked and how).
 

Dresden

New member
Joined
Jun 1, 2010
Messages
22
Reaction score
0
Points
0
If I remember correctly there is a bunch of old threads from like 2005 on here about this, some of the fixes involve unplugging battery and letting the climate control (or something) reset, trip to dealer maybe required to un-lock radio if battery unplugged etc...
 

panther

New member
Joined
May 12, 2010
Messages
17
Reaction score
0
Points
0
I just wanted to update members of the forum on my 2001 Intrigue GLS AC problem/fix...

The AC condenser was ultimately found to be the damaged culprit. After a couple of dye administrations and AC coolant recharge cycles the leak became visible in two locations on the condenser. Not "easily" noticed untill the AC condenser was finally removed.

Recall, the passenger side was initially giving off "cool/cold" air (driver side warm air). Well, after a couple days further the passenger side was delivering warm air too.

The retail cost to replace by mechanic was ~$400. Two different auto repair guides listed the estimated time to repair at 2hrs and 2.7hrs. The mechanic said it wasn't as difficult as first thought and it didn't take too much time or effort to repair. Therefore 2 hr is generously accurate for time in a repair cost estimate. National part stores list AC condenser anywhere from ~$140-$180 for part.

Its been almost 2 weeks and the AC has been amazing, delivering very cold air. So it looks as if it is finally fixed.

Thanks for all of the replies and I hope this helps someone else in future! If you have a similar problem and need guidance contact me for a thorough direct description of the symptoms, trouble shoot, diagnosis and repair process I went through.
 

Andrew Lobel

New member
Joined
Feb 10, 2016
Messages
2
Reaction score
0
Points
0
I think the mechanic you visited didn't know well about servicing the air conditioning unit. So in such cases consider visiting the mechanic who had experience in diagnosing the air conditioning problems.
 

Triguie_2000_GLS

New member
Joined
Dec 20, 2009
Messages
618
Reaction score
0
Points
0
Location
Connecticut
I think the mechanic you visited didn't know well about servicing the air conditioning unit. So in such cases consider visiting the mechanic who had experience in diagnosing the air conditioning problems.

Why in gods name are you bumping a 5.5 year old thread?

Oh wait, you're a spammer :rolleyes:
 

kimbabrt

New member
Joined
Jun 25, 2020
Messages
1
Reaction score
0
Points
1
I have a similar problem but visa versa, cold air on driver side, warm air on passenger side going to check into blender control knobs. Maybe passenger side is stuck????
 

seen_bawl

Member
Joined
Mar 8, 2014
Messages
31
Reaction score
1
Points
8
Thank you I had this problem and after I changed the blend door I left it as is, but since you discover the issue I'm going to fix this problem soon thanks again
 
Top