2001 Intrigue ABS codes C0040 and C0110

Joined
May 8, 2014
Messages
82
Reaction score
0
Points
6
Location
SE Michigan, USA
On my 2001 Oldsmobile Intrigue GX, I get two ABS codes:

1) C0040 (RF Sensor bad) --> Checked the wiring end and it's still in 1 piece
2) C0110 (ABS Pump Circuit Malfunction) --> Very rare issue

I ordered a new set of front wheel hub assemblies for my 2001 Oldsmobile Intrigue along with a new ABS Module (ACDelco), wheel hub mounting bolts, hub removal tool, anti-seize (very important), and spindle nuts when I ordered some other things and new steering components for my dad's 2005 Chevy Malibu Maxx LS 3.5L V6 Hatchback on Amazon.com

For the ABS module, that would be adjacent to the brake reservoir and under the cruise control, correct?

Also, my sister's friend said that the ABS sensor can be replaced on the wheel hub assembly, which I know he's wrong as the ABS sensor is non-removable and requires the whole assembly to be replaced.

Once I get the parts via Amazon, I will be fixing the ABS once and for all and keep the other hub assembly in case the other one on the driver's side goes out. However, I need to get 32mm-34mm sockets for removing the old spindle nut so that I can install the new one or take it to my friend's shop to get it fixed.
 
Last edited:

Cutlass350

New member
Joined
Aug 20, 2012
Messages
655
Reaction score
1
Points
0
Location
New England! :-)
Fwiw, *imho*, every hub that is not bought Directly From A Dealer is a flaming pile of ******!

Between the counterfeit cr*p, and the just plain cr*p, you have a better chance of winning a one on one with a hungry T-REX.

For the right front, first replace the sensor wire harness - buy the GM Pile Of ****** replacement harness. It's a higher quality of cheap cr*p! It will last ~6-18 months. A lot depends on the type and amount of driving.

You can not get an OEM spec sensor wire harness. Even the GM replacement cr*p has bigger wires (which will break sooner).
The original had ~600 strands of wires in that sensor wire.
The GM replacement has ~100-200.
The non GM replacement has even bigger wires, and hence fewer.


Just my 2 cents. :)
Fwiw, my car has ~225K miles on it and goes through New England winters and weather.
Plus, it deals with the potholes connected by slim patches of asphalt that we call "roads" in New England. We have a prolonged freeze/thaw season - that destroys roads more than a hungry T-REX chasing after a person. :)

Good Luck.
 
Last edited:
Joined
May 8, 2014
Messages
82
Reaction score
0
Points
6
Location
SE Michigan, USA
When I ordered the items on Amazon, the hub removal tool along with a couple of other things got sent to Dallas, TX last week. How they done messed up is beyond me. The wire harness from the hub to the module is good and hasn't broken into 2 pieces.
 

seen_bawl

Member
Joined
Mar 8, 2014
Messages
31
Reaction score
1
Points
8
I got 2001 oldsmobile intrigue I got 4 light one of them are the breaks
So here is what I done the problem still on
I changed the wheel hub, I change the connector, and the transmission sensor, abs model too, all the wire been checked very good no crack nothing suspicious
Break light is gone with another 2 error code
Now I stuck with C0040 can't get rid of it any idea please help
Transmission sensor connector has been change where is the problem???
 
Top