2001 Aurora 3.5 stalled will not restart?

unioncreek

New member
Joined
May 19, 2019
Messages
2
Reaction score
0
Points
0
I have a 2001 Aurora with the 3.5 in it. A little history, about 6 months ago the dash/gauge just stopped working for about 5 minutes and then everything was good. Car ran fine when the gauges were out. About a week ago it quit on the way to work, coasted into a pull out, it started right up. But the tach was saying 5K while the engine was idling. When I drove home that night everything was OK, tach worked. This past Friday on the way home, I was on a straight stretch and I wondered why the battery light was on, well the engine had quit. It would not restart so I pulled onto a road and walked home. We pulled it home later that evening, it wouldn't start. I was hoping it was the fuel pump, but it must have just shut off there was no chugging or anything associated like when your running out of fuel. I check the fuel pump pressure yesterday and it was at 35 pounds, and still doesn't start. When I pull it home I tried to start it and it acted like it wanted to start, but it was like it had no gas.

Someone on another forum said the fuel pressure was low, so I replaced the fuel pump and it goes to 45 psi then settles to 40 psi and stays there.

How do I test the fuel injectors to see if their getting power/signal?

Does anybody have any suggestions of what I should look at?

Thanks,
Bob
 

unioncreek

New member
Joined
May 19, 2019
Messages
2
Reaction score
0
Points
0
Finally back home after a month working out of state. Replaced the crank sensor and the Aurora is back to running. They sure make it a pain it the you know what to change that sensor.

Bob
 
Top