• In the 1980s and 1990s we used AOL and Usenet. In the 2000s there were forums and message boards. In the 2010s - and until the very near future - Facebook and Instagram. Something new is coming for Oldsmobile owners... Become an early adopter of what's next by SIGNING UP HERE. Your email address will not be sold or used in any way other than us communicating more details as we prepare for launch - and we will not communicate often.

2001 Alero "stuff"

5fty7vn

New member
Joined
Apr 6, 2016
Messages
11
Reaction score
1
Points
1
I have a 2001 Alero that I recently replaced the multi unit switch (turn signal and wiper control) on the steering column as well as the hazard switch. I installed the multi unit switch with no issues. When I put the new hazard switch on, my turn signals blink fast. Thinking it may be the multi unit I had another one sent to me with the same results. I then put the original hazard switch back in and noticed the turn signals blinked normal. I did this with all of the multi unit switches and the result was the same (this includes a second hazard switch replacement).......the new hazard switches caused my turn signals to blink faster. I have a third hazard switch ordered from Rockauto that should be here today. Has anyone ever experienced this when replacing a hazard switch? If so, is this something that is fixable without having to rely on the original parts?

Also, my center vent (the one right right above the radio) came out in pieces so i'm needing a new one if anyone knows where to find one or has one available. Mine is the gray colored vent. I've seen the same shaped vent in an Olds Intrigue. Anyone know if this is interchangeble with an Alero?
 

Onesoldier

New member
Joined
Oct 29, 2021
Messages
2
Reaction score
0
Points
1
I have the same exact issue! I changed multiple hazard switches and multi units and nothing ever got it to blink normal. However, I have tried adding a resistor to the setup as if I had added led bulbs (which I didn't) and so far it has fixed the fast blink!
 

ZZYZZX

New member
Joined
May 11, 2022
Messages
13
Reaction score
0
Points
1
OE replacement switch or aftermarket?

At least as of right now I only see aftermarket switches available on Rock Auto (at least for a 1999). Brands being SHEE-MAR and WVE.
I would only get a used one from the junkyard (unless a common failure item), a new OE one, or a new Standard Motor products one (DS-772).
I would not pay the $180 for an OE one, which is probably made in China, when I can get a Standard Motor one (not the cheaper T series) for around 105-ish.

Actually for that much money I'd try dissecting my existing one to see if I can clean the contacts.

My local junkyard charges $27 + tax and admission for one of these switches, so a used on off eBay is about the same price for me.
 
Last edited:
Top