1992 Oldsmobile Toronado Trofeo cluster failure

rogue59

New member
Joined
Aug 28, 2017
Messages
4
Reaction score
0
Points
0
was searching for a fix for the above problem. when it was still in the vehicle I experienced intermittent failure of all guard in the cluster to the point it didn't seem to work at all. I consulted the older site and thought there was a fix for the dash, or cause for this intermittent failure (and related fix), but can't seem to find anything.

my understanding was it was a dried out capacitor or leaky capacitor that had leaked??

anybody out there have any help that can help me to get this cluster working again?

thx.
 

Hoog

New member
Joined
Oct 19, 2018
Messages
23
Reaction score
0
Points
0
I have done a couple Instrument cluster repairs on my Toros. I will see if I can dig up the specs on the caps and instrucions that were sent to me. Do you still need the info?
 

Mcchevy427

New member
Joined
Jun 21, 2021
Messages
1
Reaction score
0
Points
0
was searching for a fix for the above problem. when it was still in the vehicle I experienced intermittent failure of all guard in the cluster to the point it didn't seem to work at all. I consulted the older site and thought there was a fix for the dash, or cause for this intermittent failure (and related fix), but can't seem to find anything.

my understanding was it was a dried out capacitor or leaky capacitor that had leaked??

anybody out there have any help that can help me to get this cluster working again?

thx.
Same problem only tach working.
 

retroren

Member
Joined
Nov 8, 2011
Messages
168
Reaction score
1
Points
18
Location
SE Michigan
yes, it is most likely a capacitor issue. search my posting as I have posted many photos and provide a link to an old detailed writeup of what to do to fix this problem. I gave the instructions and my cluster gauge to a radio repair shop and they fixed it in no time by replacing the $2 capacitor
 
Top