oldsmobile forums   oldsmobile forums


Go Back   Oldsmobile Forums > Older Requested Oldsmobile Models > Oldsmobile Eighty-Eight (88) > Oldsmobile 88 FWD

Notices

Oldsmobile 88 FWD Forum specifically intended for Oldsmobile Eighty-Eight (88) front wheel drive based discussions.

Oldsmobile Forum: 1995 Olds 88 3.8l cranks/fires then stalls
Reply
 
Thread Tools
  #1  
Old 3 Weeks Ago
Armour90 Armour90 is offline
Junior Member
 
Join Date: Oct 2017
Posts: 2
Armour90 is on a distinguished road
1995 Olds 88 3.8l cranks/fires then stalls

We have a 1995 Olds 88 Royale 3.8l v6 that will crank and initially fire, but then immediately stalls. Fuel pressure is fine when cranking and there is a good spark even as it stalls. Also, it randomly seems to start and run once in a while. Had a mechanic look at it and they couldn't find the problem. He thought it may be a security issue with the lock cylinder, or possibly a cam position sensor. I get no security dash light though.

Any recommendations would be welcome.
Reply With Quote

  #2  
Old 2 Weeks Ago
NINETY EIGHT REGENCY's Avatar
NINETY EIGHT REGENCY NINETY EIGHT REGENCY is offline
Administrator
ADMINISTRATOR
 
Join Date: Apr 2004
Location: HOUSTON,TEXAS
Posts: 1,756
NINETY EIGHT REGENCY has disabled reputation
Look at:
spark plugs
spark plug wires
fuel filter
fuel pump
ignition module
coil packs
crankshaft position sensor
Throttle position sensor
__________________

RANSOM ELI OLDS REINCARNATED
Reply With Quote
  #3  
Old 2 Weeks Ago
Armour90 Armour90 is offline
Junior Member
 
Join Date: Oct 2017
Posts: 2
Armour90 is on a distinguished road
Thanks for the recommendations. We've looked at everything prior to coil packs. We will keep troubleshooting.

Update...I was able to start the car the other day. It ran fine and drove about 2 hours to get it home. When I got there, it immediately started and ran after shutting down. The next day, it was back to the same issue.
Reply With Quote
  #4  
Old 2 Weeks Ago
Cutlass350 Cutlass350 is offline
Senior Member
 
Join Date: Aug 2012
Location: New England! :-)
Posts: 610
Cutlass350 is on a distinguished road
Imho, you're likely going to have to "throw parts" at the problems. I generally don't like advising people to do that. But, imho, other than bringing it to a dealer, and spending likely at least $700 (diag & parts), imho that's the best option.


Fwiw, my suggestions - from my experience baby sitting my '92 Olds daily driver (until last year) for many years...
Now, my 2000 Olds is my daily driver. Hey, someone has to be driving an Oldsmobile.

1) The Crank Position sensor on GM cars often fail like you've mentioned. DESPITE the fact that they have two separate sensors in one housing, and should be super reliable.

1A) Buy only 100% GM/Delco sensors, from a reliable source (imho, you local autozone/etc is not a reliable source (they've bought many fake parts over the years).


2) Bypass the security.

3) Replace the cam sensor. Again, GM/Delco-only parts!

4) Replace the coils. Again, GM/Delco-only parts!

5) Replace the ignition module. Again, GM/Delco-only parts!
Note, new is $$$.
Maybe get an used one from ebay?? It'll "likely" be good.

6) Use only the spark plugs that are called out on the emissions sticker. For some reason, GM cars can be super picky with spark plugs. Especially as the engine wears and gets older.
I was lucky in finding "new Old Stock" spark plugs for my '92. That's after $$$$$$ in new coils, ignition module, spark plug boots, coil cover, battery, fuel filter, injectors, etc. The engine had a bad skip. In the winter, with a cold engine, it might even stall. I also tried every other spark plug.
I put in the New Old Stock spark plugs, and I was like "NO F*******ING WAY!!!!!" that was the problem. :-O
I swapped 4 times. With the New Old Stock spark plugs, the engine was okay. Any other spark plug, and it would have skip.
Fwiw, the engine sounds like a very loud old sewing machine. Over 10 years ago, I thought that the heads and valve train had it. Today, It still gets ~28->30mpg, passes smog, etc. But, the uni-body is rusting away to nothingness.
My best guess is that the engine is so worn, it doesn't like the spark pattern of the other plugs.
Btw, the EFI fuel trim is still under 5% - so, no leaks or super bad valves/rings/etc.

7) Do a compression test. Note, regardless of what BS you read on the interweb, compression tests are far from accurate or definitive. They can show bad cylinders. But, cylinders can look good and be bad. Or, look bad and be okay (less likely - but possible).


Good Luck.

Last edited by Cutlass350; 2 Weeks Ago at 03:48 AM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -4. The time now is 11:22 AM.


Advertising
cars connected social network cars connected social networking app for ios cars connected social networking app for android

suspension parts, shocks, struts and more




Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
oldsmobileforums.com recognizes that "Oldsmobile", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. oldsmobileforums.com is not affiliated in any way with the General Motors Corporation, Oldsmobile or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 oldsmobileforums.com. All rights reserved.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Oldsmobile? Check out your options at the links below:

Miss that Olds 442? Believe it or not, Kia may have something for you. The Kia Stinger is a large sport-oriented hatchback sedan in the mold of the Audi A7.